DGU Feedback form currently down
Incident Report for GOV.UK
Resolved
The data.gov.uk contact form has now been removed. Users are now directed to use the main GOV.UK contact form.
Posted Apr 30, 2024 - 09:48 BST
Investigating
We are currently investigating this issue.
Posted Apr 02, 2024 - 11:49 BST
This incident affected: www.data.gov.uk.