We've successfully tested the fix for draft-frontend and are finalising its implementation. We'll provide another update tomorrow.
Posted Sep 10, 2026 - 16:35 BST
Update
We've shipped a change to Whitehall to minimise the impact of this issue. Publishers using Whitehall normally should now be able to edit documents and see the images in the Images tab - and on the document preview - with no issues.
The intermittent image-rendering continues to be a problem when clicking on a preview URL (for example, a URL shared by a colleague) and not navigating to it directly from Whitehall. We've identified a fix for that and hope to have an update tomorrow.
Posted Sep 09, 2026 - 16:08 BST
Identified
We've identified the root cause of the issue: draft documents with more than one image can fail to pass authentication when requesting those images from Asset Manager, due to the random order in which the authentication 'callbacks' can happen. The issue does resolve itself when the document is published (the images become live and no authentication is required).
We are aware of intermittent issues with the rendering of images, both in Whitehall's Admin UI and in the draft 'preview'. We believe this affects drafts only, and that there are no issues viewing images once the document is published. Meanwhile, we are investigating the underlying cause as a matter of priority.